Troubleshooting: CredSSP Error Messages
Error Message(s)
CredSSP authentication is currently disabled in the client configuration
Cause(s)
Whenever a system like a Remote PowerShell connection or a CoreOne Suite System Connectors establishes a connection to the Microsoft Exchange server, the provided credentials are just valid for that connection. In some cases the Microsoft Exchange server tries to set additional properties on the users Active Directory account. In order to do this, the Microsoft Exchange server executes those actions on a Domain Controller and therefore connects to a third party. In order to do this in the context of the user, the credentials must be passed to this third party. By default, this is disabled and the call will result in an error message.
Solution(s)
In order to pass the credentials to any third party, we must configure and enable CredSSP
. To do so, please follow the steps below:
Test if CredSSP is working:
$session = New-PSSession -ConfigurationName Microsoft.Exchange -ConnectionUri http://exchangeUrl/PowerShell -Authentication Credssp -Credential $cred
If this failed:
Enable CredSSP on the Exchange Server:Â
Enable-WSManCredSSP -Role "Server"
On all clients like the CoreOne System Connector and such enable CredSSP:Â
Should the connection only be possible over Port 80 (HTTP), run the following command on both systems
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