Troubleshooting: TOTP does not work or runs into a timeout

Issue(s)

A user tries to configure a new TOTP device. After scanning the QR code and entering the PIN the request ends in an error message after 1 minute.

A user tries to authenticate using a TOTP device and after entering the PIN the requests takes over 30 seconds to perform or even runs into an error.

Cause(s)

In order to generate and validate the PIN, the authentication servers needs an accurate time. For this a periodic time sync with a time server is needed. If the server has no internet access and no local NTP server is configured, the sync will run in a time out.

Solution(s)

  • Add a time server to CoreOne Authentication Service settings NtpTimeServer, NistTimeServer or HttpTimeServer (available for versions >= 6.x)

  • Configure a local NTP server and point one of the servers documented here to that server.

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